$re = '/```(.*?)```/s';
$str = 'head of file
```
code
```
docs text
```
code2
```
end of file';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);