import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xim)\n"
+ " ^ # BOL\n"
+ " (?P<path>..[^:]*) # path\n"
+ " :: # two colons\n"
+ " (?:(?P<warning>WARN)|(?P<error>ERROR)) # WARN or ERROR\n"
+ " :: # two colons\n"
+ " \\s # whitespace\n"
+ " \\( # left brace\n"
+ " \\s* # optional whitespace\n"
+ " (?P<line>[0-9]+) # named group: line\n"
+ " , # comma\n"
+ " \\s* # optional whitespace\n"
+ " (?P<col>[0-9]+) # named group: col\n"
+ " \\) # right brace\n"
+ " \\: # colon\n"
+ " \\s # whitespace\n"
+ " (?P<message>.*) # named group: message\n"
+ " $ # EOL\n"
+ " ";
final String string = "/Users/bb/Downloads/test.lsl::ERROR:: ( 5, 30): syntax error, unexpected ','\n"
+ "TOTAL:: Errors: 1 Warnings: 0\n"
+ "C:\\Users\\bb\\Downloads\\test.lsl::ERROR:: ( 5, 30): syntax error, unexpected ','\n"
+ "TOTAL:: Errors: 1 Warnings: 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}