// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?xim)
^ # BOL
(?P<path>..[^:]*) # path
:: # two colons
(?:(?P<warning>WARN)|(?P<error>ERROR)) # WARN or ERROR
:: # two colons
\s # whitespace
\( # left brace
\s* # optional whitespace
(?P<line>[0-9]+) # named group: line
, # comma
\s* # optional whitespace
(?P<col>[0-9]+) # named group: col
\) # right brace
\: # colon
\s # whitespace
(?P<message>.*) # named group: message
$ # EOL
").unwrap();
let string = "/Users/bb/Downloads/test.lsl::ERROR:: ( 5, 30): syntax error, unexpected ','
TOTAL:: Errors: 1 Warnings: 0
C:\\Users\\bb\\Downloads\\test.lsl::ERROR:: ( 5, 30): syntax error, unexpected ','
TOTAL:: Errors: 1 Warnings: 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}