using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*\s*[!<>=](?>\=)?\s*\d+$|^\d*\s*<>\d+";
string input = @">100
<100
>=100
<=100
=100
!=100
==100
> 100
> 100
!= 100
== 100
100
===100
<<100
=<100
<>100
100 != 100
100 == 100
100 < 99
100 > 99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}