re = /^\d*\s*[!<>=](?>\=)?\s*\d+$|^\d*\s*<>\d+/m
str = '>100
<100
>=100
<=100
=100
!=100
==100
> 100
> 100
!= 100
== 100
100
===100
<<100
=<100
<>100
100 != 100
100 == 100
100 < 99
100 > 99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end