#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)error(?!s=)"
Local $sString = "1 sample text, more text, errors=123456 more text more text" & @CRLF & _
"2 drops=0 link status good errors=0 adapter" & @CRLF & _
"3 Error: process failed to start" & @CRLF & _
"4 process [ERROR] failed" & @CRLF & _
"5 this line might have both ERROR and error=5555 and more text" & @CRLF & _
"6 there might be a line that has error=0x02343329 ERROR and more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")