re = /error(?!s=)/mi
str = '1 sample text, more text, errors=123456 more text more text
2 drops=0 link status good errors=0 adapter
3 Error: process failed to start
4 process [ERROR] failed
5 this line might have both ERROR and error=5555 and more text
6 there might be a line that has error=0x02343329 ERROR and more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end