package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);`)
var str = `<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}