import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);";
final String string = "<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}