import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\+]{1})?(?:\\([0-9]{1,2}\\) ?)?(?:[0-9] ?-?){6,14}[0-9]$";
final String string = "+(57) 321 233 38 62\n"
+ "+(57)3212333862\n"
+ "+(57) 3212333862\n"
+ "+573212333862\n"
+ "+57 3212333862\n"
+ "+57 321 2333862\n"
+ "+57 321 233 38 62\n"
+ "+57 321 233 3862\n"
+ "+57 321-233-3862\n"
+ "57 3212333862\n"
+ "573212333862\n"
+ "3212333862\n"
+ "321 233 38 62\n"
+ "321 233 3862\n"
+ "321-233-3862\n"
+ "321-233-38-62\n"
+ "321-2333862\n"
+ "3212333862\n"
+ "0317245696\n"
+ "031 7245696\n"
+ "031 724 56 96\n"
+ "031 724 5696\n"
+ "031-7245696\n"
+ "031-724-56-96\n"
+ "031-724-5696\n"
+ "7245696\n"
+ "724 56 96\n"
+ "724 5696\n"
+ "724-56-96\n"
+ "724-5696";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}