$re = '/^(?:[\+]{1})?(?:\([0-9]{1,2}\) ?)?(?:[0-9] ?-?){6,14}[0-9]$/mi';
$str = '+(57) 321 233 38 62
+(57)3212333862
+(57) 3212333862
+573212333862
+57 3212333862
+57 321 2333862
+57 321 233 38 62
+57 321 233 3862
+57 321-233-3862
57 3212333862
573212333862
3212333862
321 233 38 62
321 233 3862
321-233-3862
321-233-38-62
321-2333862
3212333862
0317245696
031 7245696
031 724 56 96
031 724 5696
031-7245696
031-724-56-96
031-724-5696
7245696
724 56 96
724 5696
724-56-96
724-5696';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;