#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:_\(|_n\()(?:[^()]*\([^()]*\))*[^()]*\)"
Local $sString = "_("foo") // want "foo"" & @CRLF & _
"_n("bar", "baz", 42); // want "bar", "baz", 42" & @CRLF & _
"_n(domain, "bux", var); // want domain, "bux", var" & @CRLF & _
"_( "one (optional)" ); // want "one (optional)"" & @CRLF & _
"apples === 0 ? _( "No apples" ) : _n("%1 apple", "%1 apples", apples)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")