package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:_\(|_n\()(?:[^()]*\([^()]*\))*[^()]*\)`)
var str = `_("foo") // want "foo"
_n("bar", "baz", 42); // want "bar", "baz", 42
_n(domain, "bux", var); // want domain, "bux", var
_( "one (optional)" ); // want "one (optional)"
apples === 0 ? _( "No apples" ) : _n("%1 apple", "%1 apples", apples)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}