$re = '/^(?!https?:\/\/)\w+(\.\w+)+$/im';
$str = 'https://google.com
http://google.com
google.com
subdomain.google.com
google.com/
google';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);