re = /^(?!https?:\/\/)\w+(\.\w+)+$/im
str = 'https://google.com
http://google.com
google.com
subdomain.google.com
google.com/
google'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end