import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d))\\b";
final String string = "127.0.0.1 12.12.12 3.1.2.5 23.52.121.25 23.12.155.255 255.255.255.256 255.255.255.255 01.12.14.54 1.12.14.54";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}