const regex = new RegExp('\\b((?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d)\\.(?:25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]\\d|\\d))\\b', 'g')
const str = `127.0.0.1 12.12.12 3.1.2.5 23.52.121.25 23.12.155.255 255.255.255.256 255.255.255.255 01.12.14.54 1.12.14.54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}