import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(U)(AA|AB|BA|BB|CC|CD|EA|FA|GA|HA|IA|JA|AE|CE|GE|FB|JB|GB|HL|IL|JL)(E|U|W)(E)(DN|AZ)(\\d{2,2})(\\d)(\\d{8,8})$";
final String string = "UCCUEDN15000003676";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}