re = /^(U)(AA|AB|BA|BB|CC|CD|EA|FA|GA|HA|IA|JA|AE|CE|GE|FB|JB|GB|HL|IL|JL)(E|U|W)(E)(DN|AZ)(\d{2,2})(\d)(\d{8,8})$/i
str = 'UCCUEDN15000003676'
# Print the match result
str.match(re) do |match|
puts match.to_s
end