import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<li.*<input type=\"checkbox\" >)(.*\\n*.*)(</li>)";
final String string = "<li class=\"task-list-item\"><input type=\"checkbox\" > Der Unit-Test <code>contextMenuReplacesText</code> wurde auskommentiert um die ausführung zu verhindern. Dieser Test funktioniert in meiner Umgebung nicht wie erwachtet. (Tastatur Layout?, Aktivierte Sprache des Betriebsystems?)\n"
+ " Datei: <code>X:\\pdfsam\\pdfsam-fx\\src\\test\\java\\org\\pdfsam\\ui\\prefix\\PrefixFieldTest.java</code></li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}