#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^[^']*\K'|'(?=[^']*$)|;(?=[^;]*$)"
Local $sString = "asdasd 'asdsad 'asdsad 'sadsad'asdasd;asd" & @CRLF & _
"adasdasd" & @CRLF & _
"asdasd;asdasd;asd"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)