using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^']*\K'|'(?=[^']*$)|;(?=[^;]*$)";
string substitution = @"";
string input = @"asdasd 'asdsad 'asdsad 'sadsad'asdasd;asd
adasdasd
asdasd;asdasd;asd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}