$re = '/;(?=[^;]*$)/im';
$str = 'asdasd \'asdsad \'asdsad \'sadsad\'asdasd;asd
adasdasd
asdasd;asdasd;asd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;