import re
regex = re.compile(r";(?=[^;]*$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("asdasd 'asdsad 'asdsad 'sadsad'asdasd;asd\n"
"adasdasd\n"
"asdasd;asdasd;asd")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)