import re
regex = re.compile(r"(?:([0-2]?[1-9]):([0-5][0-9])(?: ?([ap]m?))?|([0-2]?[1-9])(?: ?([ap]m?)))", flags=re.IGNORECASE)
test_str = ("5am\n"
"5 pm\n"
"5:00am\n"
"4:20pm\n"
"2:20 AM\n"
"12:00 pm\n"
"12:00am\n"
"8:00\n"
"12:00\n"
"8pm\n"
"7:pm\n"
"5:00\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")