package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-zA-Z]+$`)
var str = `476pe
e586
9999
rrr
ABCF
test
333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}