$re = '/^[a-zA-Z]+$/mi';
$str = '476pe
e586
9999
rrr
ABCF
test
333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);