package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^, ]+ [^, ]+`)
var str = `A, B, C,
1, 2 1, 3,
3, 1, 0,
4, 1, 0 5,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}