$re = '/[^, ]+ [^, ]+/m';
$str = 'A, B, C,
1, 2 1, 3,
3, 1, 0,
4, 1, 0 5,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);