import Foundation
let pattern = #"Cliente:(.*)CPF\/C\.N\.P\.J\.:(.*)\sEndereço:(.*)CEP:(.*)\s{1,}Tel EBT:\s{1,}Tel Res:(.*)Tel Outros:(.*)Tel Comercial:(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
RETIRAR ANTENA E LNB.
Cliente:
FULANO DE TAL CPF/C.N.P.J.: 123456789123
Endereço: R RITA ALVES PEREIRA , 01 -
CARAPICUIBA -CARAPICUIBA-SP CEP: 6365000
Tel EBT:
Tel Res:
01141874187 Tel Outros: Tel Comercial: 011999999999
Tel Celular: Tel Fax:
Referência (Localização):
Solicitação: 13/06/2014 23:02 Emissão: 15/06/2014 13:38 Node: CARAP06365
Agendado para: 28/06/2014 INTEGRAL OS Número: 0000000010
EQUIPE: PARCEIRO: C111111_S_SP-XXXXXXX
Prepostos: Portabilidade:
Contrato: 00000008 Produto: Qtde. de Pontos: 1 Data de Habilitação: 13/02/2013
EQUIPAMENTOSNr. Série: Produto Atual: Produto Novo: Mod.Venda: Localização: Tipo/Modelo: Instalação:
000000000012 PCT COMP NV FACIL FID_2012 COMODATO OUTROS DECODER DIGITAL -COSHIP -N5366S (PenVR)
000000000012 PCT COMP NV FACIL FID_2012 COMODATO OUTROS SMART CARD -NAGRA 13/02/2013
SERVIÇOSEXECUTADOSData: Serviço executado: Equipe: Parceiro: Cód. Baixa:
13/02/2013 ADESAO -INSTALACAO DE ASSINATURA DIGITAL C111111_S_SP-XXXXXXX EXEC. -Instalação
SERVIÇOSSOLICITADOSOS: Tipo de OS: Produto: Tipo Equip.:
0000000010 DESCONEXAO INV SD
OBS.
[ AGENDAMENTO AUTOMÃTICO FEITO VIA JOB DE BANCO 15/06/2014 01:07:27 [Agendamento para 28/06/2014 (INTEGRAL) feito por PROD_JD em 15/06/2014 01:07 :27]
Obs.
Parceiro
MATERIAIS UTILIZADOS / RETIRADOS
CÓDIGO MATERIAIS DTH QTDE. CÓDIGO MATERIAIS HFC QTDE. CÓDIGO MATERIAIS QTDE.
70075212 Antena Offset de 60 cm 70084526 Conector F selado (outdoor)
70075213 Antena Offset de 90 cm 70084554 Fita plástica dielétrica
70084888 Antena UHF LOG PRDC 470-890MHZ 70084567 Fecho para fita plástica dielétrica
70075215 LNBF Simples 70084553 Gancho span clamp U
70075217 LNBF Duplo 70084522 Cabo RG-6 tri-shield preto com mensageiro
70084119 LNBF Banda KU Quádruplo Universal 70084568 Pitão com flange e bucha S10
70075208 Kit Fixação 70084579 Bucha para passagem coaxial
70075209 Kit Instalação 70084527 Emenda F
70075622 Conector Tipo F Hexagonal 70084523 Cabo RG-6 tri-shield branco sem
mensageiro
70084525 Conector Tipo F compressão 70084525 Conector F (indoor) Compressão
70075417 Diplexer VHF/UHF -SAT
MOV.DE EQUIPAMENTOS
Nr. Série Localização Instalado Retirado
NÃveis DTH NÃveis HFC
QS NS MER BER C.Alto C.Baixo
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
M.Terrestre | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
OBSERVAÇÕESCERTIDÃO DE NASCIMENTO| | | | | | | | | | | | | |
Executado pela Equipe: Hora de Entrada: Hora de SaÃda: Cód. Baixa:
DOCUMENTOS ENTREGUES: ( ) Conta de Telefone ( ) Ãgua/Luz/Gás ( ) Extrato Bancário ( ) Capa carnê IPTU ( ) Fatura Cartão de Crédito
( ) Instalação Casa / ( ) Instalação Prédio : ( ) Sacada ( ) Cobertura Prédio ( ) Chave SMU
IMPORTANTE: LEIA ATENTAMENTE ANTES DE ASSINAR
Ao assinar este documento, declaro estar ciente:
1) Que o SERVIÇO contratado será prestado com base nos termos e condições do CONTRATO DE PRESTAÇÃO DO SERVIÇO DE TV POR ASSINATURA VIA SATÉLITE, BANDA LARGA E TELEFONIA; 2) De ter recebido cópia do contrato o qual
li e concordo com os termos e condições nesse mencionado; 3) Do direito previsto no Artigo 49 do Código de Defesa do Consumidor; 4) Que a desconexão do serviço não me isenta da quitação de débitos pendentes relativos aos serviços prestados
até a data de solicitação nem ao pagamento em virtude de quebra de fidelidade, ficando a Embratel –TV Sat, autorizada nesses casos a cobrar o valor corrigido do benefÃcio utilizado; 5) Que as visitas técnicas serão cobradas conforme condições
estabelecidas no contrato; 6) Que os equipamentos instalados e cedidos em modelo de comodato estão sob minha responsabilidade, devendo devolve-los no momento de rescisão em condições perfeitas. Caso seja detectado pelos técnicos avarias ou
adulterações, haverá cobrança a tÃtulo de reposição dos equipamentos.
Procedimento Autorizado por Regime Especial -Processo nº 31820-273877/2009
Técnico ensinou a usar o sistema: Sim ( ) Não ( )
Qualidade dos canais abertos antes da visita: Bom ( ) Ruim ( )
Sistema Embratel TV funcionando em perfeitas condições, testados com o cliente/preposto: Sim ( ) Não ( )
Houve danos no imóvel ou equipamentos, e este(s) descrito(s) acima: Sim ( ) Não ( )
Avaliação do serviço
técnico realizado:
(Péssimo) 0 «-» 10 (Ótimo)
__________________________
Indique um amigo
Nome: ______________________________________
Telefone: (______) ____________________________
_______________________ ___/___/___ ___________________________ ______________ ___________________________
Assinatura da Equipe Técnica Data Nome do Cliente ou Preposto CPF / CNPJ Assinatura do Cliente ou Preposto
RETIRAR ANTENA E LNB.
Cliente: OUTRO FULANO DE TAL CPF/C.N.P.J.: 00000000011
Endereço: R ANTONIO FL, 01 -VILA DIRCE -CARAPICUIBA-SP CEP: 6343000
Tel EBT:
Tel Res: 01141464146 Tel Outros: Tel Comercial: 011999999999
Tel Celular: Tel Fax:
Referência (Localização):
Solicitação: 14/06/2014 07:18 Emissão: 15/06/2014 13:38 Node: CARAP06343
Agendado para: 30/06/2014 INTEGRAL OS Número: 0000000010
EQUIPE: PARCEIRO: C111111_S_SP-XXXXXXX
Prepostos: Portabilidade:
Contrato: 00000008 Produto: Qtde. de Pontos: 1 Data de Habilitação: 11/01/2013
EQUIPAMENTOSNr. Série: Produto Atual: Produto Novo: Mod.Venda: Localização: Tipo/Modelo: Instalação:
000000000012 PACOTE CANCELAMENTO FID COMODATO SALA DECODER DIGITAL -HUAWEI -DS222 (PenVR)
000000000012 PACOTE CANCELAMENTO FID COMODATO SALA SMART CARD -NAGRA 20/03/2014
SERVIÇOSEXECUTADOSData: Serviço executado: Equipe: Parceiro: Cód. Baixa:
12/11/2013 MUDANCA DE LOCAL DE PONTO DIGITAL/ANTENA C111111_S_SP-XXXXXXX EXEC.-Refeitas As
11/01/2013 ADESAO -INSTALACAO DE ASSINATURA DIGITAL C111111_S_SP-XXXXXXX EXEC. -Instalação
SERVIÇOSSOLICITADOSOS: Tipo de OS: Produto: Tipo Equip.:
0000000010 DESCONEXAO INV SD
OBS.
[ AGENDAMENTO AUTOMÃTICO FEITO VIA JOB DE BANCO 14/06/2014 23:30:31 [Agendamento para 30/06/2014 (INTEGRAL) feito por PROD_JD em 14/06/2014 23:30 :31]
Obs.
Parceiro
MATERIAIS UTILIZADOS / RETIRADOS
CÓDIGO MATERIAIS DTH QTDE. CÓDIGO MATERIAIS HFC QTDE. CÓDIGO MATERIAIS QTDE.
70075212 Antena Offset de 60 cm 70084526 Conector F selado (outdoor)
70075213 Antena Offset de 90 cm 70084554 Fita plástica dielétrica
70084888 Antena UHF LOG PRDC 470-890MHZ 70084567 Fecho para fita plástica dielétrica
70075215 LNBF Simples 70084553 Gancho span clamp U
70075217 LNBF Duplo 70084522 Cabo RG-6 tri-shield preto com mensageiro
70084119 LNBF Banda KU Quádruplo Universal 70084568 Pitão com flange e bucha S10
70075208 Kit Fixação 70084579 Bucha para passagem coaxial
70075209 Kit Instalação 70084527 Emenda F
70075622 Conector Tipo F Hexagonal 70084523 Cabo RG-6 tri-shield branco sem
mensageiro
70084525 Conector Tipo F compressão 70084525 Conector F (indoor) Compressão
70075417 Diplexer VHF/UHF -SAT
MOV.DE EQUIPAMENTOS
Nr. Série Localização Instalado Retirado
NÃveis DTH NÃveis HFC
QS NS MER BER C.Alto C.Baixo
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
M.Terrestre | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
OBSERVAÇÕESCERTIDÃO DE NASCIMENTO| | | | | | | | | | | | | |
Executado pela Equipe: Hora de Entrada: Hora de SaÃda: Cód. Baixa:
DOCUMENTOS ENTREGUES: ( ) Conta de Telefone ( ) Ãgua/Luz/Gás ( ) Extrato Bancário ( ) Capa carnê IPTU ( ) Fatura Cartão de Crédito
( ) Instalação Casa / ( ) Instalação Prédio : ( ) Sacada ( ) Cobertura Prédio ( ) Chave SMU
IMPORTANTE: LEIA ATENTAMENTE ANTES DE ASSINAR
Ao assinar este documento, declaro estar ciente:
1) Que o SERVIÇO contratado será prestado com base nos termos e condições do CONTRATO DE PRESTAÇÃO DO SERVIÇO DE TV POR ASSINATURA VIA SATÉLITE, BANDA LARGA E TELEFONIA; 2) De ter recebido cópia do contrato o qual
li e concordo com os termos e condições nesse mencionado; 3) Do direito previsto no Artigo 49 do Código de Defesa do Consumidor; 4) Que a desconexão do serviço não me isenta da quitação de débitos pendentes relativos aos serviços prestados
até a data de solicitação nem ao pagamento em virtude de quebra de fidelidade, ficando a Embratel –TV Sat, autorizada nesses casos a cobrar o valor corrigido do benefÃcio utilizado; 5) Que as visitas técnicas serão cobradas conforme condições
estabelecidas no contrato; 6) Que os equipamentos instalados e cedidos em modelo de comodato estão sob minha responsabilidade, devendo devolve-los no momento de rescisão em condições perfeitas. Caso seja detectado pelos técnicos avarias ou
adulterações, haverá cobrança a tÃtulo de reposição dos equipamentos.
Procedimento Autorizado por Regime Especial -Processo nº 31820-273877/2009
Técnico ensinou a usar o sistema: Sim ( ) Não ( )
Qualidade dos canais abertos antes da visita: Bom ( ) Ruim ( )
Sistema Embratel TV funcionando em perfeitas condições, testados com o cliente/preposto: Sim ( ) Não ( )
Houve danos no imóvel ou equipamentos, e este(s) descrito(s) acima: Sim ( ) Não ( )
Avaliação do serviço
técnico realizado:
(Péssimo) 0 «-» 10 (Ótimo)
__________________________
Indique um amigo
Nome: ______________________________________
Telefone: (______) ____________________________
_______________________ ___/___/___ ___________________________ ______________ ___________________________
Assinatura da Equipe Técnica Data Nome do Cliente ou Preposto CPF / CNPJ Assinatura do Cliente ou Preposto
RETIRAR ANTENA E LNB.
Cliente: MAIS UM FULANO DE TAL CPF/C.N.P.J.: 00000000011
Endereço: R TIBIRICA, 00 -VILA DIRCE -CARAPICUIBA-SP CEP: 6335000
Tel EBT:
Tel Res: 01141674167 Tel Outros: Tel Comercial:
Tel Celular: 011999999999 Tel Fax:
Referência (Localização):
Solicitação: 14/06/2014 05:50 Emissão: 15/06/2014 13:38 Node: CARAP06335
Agendado para: 30/06/2014 INTEGRAL OS Número: 0000000010
EQUIPE: PARCEIRO: C111111_S_SP-XXXXXXX
Prepostos: Portabilidade:
Contrato: 00000008 Produto: Qtde. de Pontos: 2 Data de Habilitação: 26/06/2010
EQUIPAMENTOSNr. Série: Produto Atual: Produto Novo: Mod.Venda: Localização: Tipo/Modelo: Instalação:
000000000012 PACOTE COMPLETO ESSENCIAL FIDELIDADE COMODATO OUTROS SMART CARD -NAGRA 26/05/2012
000000000012 PACOTE COMPLETO ESSENCIAL FIDELIDADE COMODATO OUTROS DECODER DIGITAL -HUAWEI -DS220 (PenVR)
000000000012 PACOTE COMPLETO ESSENCIAL FIDELIDADE COMODATO OUTROS DECODER DIGITAL -COSHIP -N5166 (SD)
000000000012 PACOTE COMPLETO ESSENCIAL FIDELIDADE COMODATO OUTROS SMART CARD -NAGRA 26/06/2010
SERVIÇOSEXECUTADOSData: Serviço executado: Equipe: Parceiro: Cód. Baixa:
26/05/2012 INSTALACAO DE PONTO EXTRA DIGITAL C111111_S_SP-XXXXXXX EXEC. -Instalação
26/06/2010 ADESAO -INSTALACAO DE ASSINATURA DIGITAL C111111_S_SP-XXXXXXX EXEC. -Instalação
SERVIÇOSSOLICITADOSOS: Tipo de OS: Produto: Tipo Equip.:
0000000010 DESCONEXAO INV SD
OBS.
[ AGENDAMENTO AUTOMÃTICO FEITO VIA JOB DE BANCO 15/06/2014 02:13:03 [Agendamento para 30/06/2014 (INTEGRAL) feito por PROD_JD em 15/06/2014 02:13 :03]
Obs.
Parceiro
MATERIAIS UTILIZADOS / RETIRADOS
CÓDIGO MATERIAIS DTH QTDE. CÓDIGO MATERIAIS HFC QTDE. CÓDIGO MATERIAIS QTDE.
70075212 Antena Offset de 60 cm 70084526 Conector F selado (outdoor)
70075213 Antena Offset de 90 cm 70084554 Fita plástica dielétrica
70084888 Antena UHF LOG PRDC 470-890MHZ 70084567 Fecho para fita plástica dielétrica
70075215 LNBF Simples 70084553 Gancho span clamp U
70075217 LNBF Duplo 70084522 Cabo RG-6 tri-shield preto com mensageiro
70084119 LNBF Banda KU Quádruplo Universal 70084568 Pitão com flange e bucha S10
70075208 Kit Fixação 70084579 Bucha para passagem coaxial
70075209 Kit Instalação 70084527 Emenda F
70075622 Conector Tipo F Hexagonal 70084523 Cabo RG-6 tri-shield branco sem
mensageiro
70084525 Conector Tipo F compressão 70084525 Conector F (indoor) Compressão
70075417 Diplexer VHF/UHF -SAT
MOV.DE EQUIPAMENTOS
Nr. Série Localização Instalado Retirado
NÃveis DTH NÃveis HFC
QS NS MER BER C.Alto C.Baixo
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
DEC | | | | | | | | | | |
SC | | | | | | | | | | |
M.Terrestre | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
EMTA | | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
CHAVE SMU | | | | | | | | | | | | |
OBSERVAÇÕESCERTIDÃO DE NASCIMENTO| | | | | | | | | | | | | |
Executado pela Equipe: Hora de Entrada: Hora de SaÃda: Cód. Baixa:
DOCUMENTOS ENTREGUES: ( ) Conta de Telefone ( ) Ãgua/Luz/Gás ( ) Extrato Bancário ( ) Capa carnê IPTU ( ) Fatura Cartão de Crédito
( ) Instalação Casa / ( ) Instalação Prédio : ( ) Sacada ( ) Cobertura Prédio ( ) Chave SMU
IMPORTANTE: LEIA ATENTAMENTE ANTES DE ASSINAR
Ao assinar este documento, declaro estar ciente:
1) Que o SERVIÇO contratado será prestado com base nos termos e condições do CONTRATO DE PRESTAÇÃO DO SERVIÇO DE TV POR ASSINATURA VIA SATÉLITE, BANDA LARGA E TELEFONIA; 2) De ter recebido cópia do contrato o qual
li e concordo com os termos e condições nesse mencionado; 3) Do direito previsto no Artigo 49 do Código de Defesa do Consumidor; 4) Que a desconexão do serviço não me isenta da quitação de débitos pendentes relativos aos serviços prestados
até a data de solicitação nem ao pagamento em virtude de quebra de fidelidade, ficando a Embratel –TV Sat, autorizada nesses casos a cobrar o valor corrigido do benefÃcio utilizado; 5) Que as visitas técnicas serão cobradas conforme condições
estabelecidas no contrato; 6) Que os equipamentos instalados e cedidos em modelo de comodato estão sob minha responsabilidade, devendo devolve-los no momento de rescisão em condições perfeitas. Caso seja detectado pelos técnicos avarias ou
adulterações, haverá cobrança a tÃtulo de reposição dos equipamentos.
Procedimento Autorizado por Regime Especial -Processo nº 31820-273877/2009
Técnico ensinou a usar o sistema: Sim ( ) Não ( )
Qualidade dos canais abertos antes da visita: Bom ( ) Ruim ( )
Sistema Embratel TV funcionando em perfeitas condições, testados com o cliente/preposto: Sim ( ) Não ( )
Houve danos no imóvel ou equipamentos, e este(s) descrito(s) acima: Sim ( ) Não ( )
Avaliação do serviço
técnico realizado:
(Péssimo) 0 «-» 10 (Ótimo)
__________________________
Indique um amigo
Nome: ______________________________________
Telefone: (______) ____________________________
_______________________ ___/___/___ ___________________________ ______________ ___________________________
Assinatura da Equipe Técnica Data Nome do Cliente ou Preposto CPF / CNPJ Assinatura do Cliente ou Preposto
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)