$re = '/^(\s*<br\s*\/?>\s*)+|(\s*<br\s*\/?>\s*)+$/';
$str = '<br> <br > <br > <br/> <br /> <br />some text<br> <br />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);