re = /^(\s*<br\s*\/?>\s*)+|(\s*<br\s*\/?>\s*)+$/
str = '<br> <br > <br > <br/> <br /> <br />some text<br> <br />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end