#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\s*<br\s*\/?>\s*)+|(\s*<br\s*\/?>\s*)+$"
Local $sString = "<br> <br > <br > <br/> <br /> <br />some text <br /><br /> The 2 middle br's shouldn't be removed. Only the beginning and the end ones are. <br /><br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")