$re = '/^(\s*<br\s*\/?>\s*)+|(\s*<br\s*\/?>\s*)+$/';
$str = '<br> <br > <br > <br/> <br /> <br />some text <br /><br /> The 2 middle br\'s shouldn\'t be removed. Only the beginning and the end ones are. <br /><br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);