package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ ?\d+[\d ,\.]*[B-DF-HJ-NP-TV-Z\/]*%?`)
var str = `0,9% BB
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}