$re = '/^ ?\d+[\d ,\.]*[B-DF-HJ-NP-TV-Z\/]*%?/m';
$str = '0,9% BB
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);