package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^|\.)((25[0-5])|(2[0-4]\d)|(1\d\d)|([1-9]?\d))){4}/(?:\d|[12]\d|3[01])$`)
var str = `10.120.15.30/28
172.181.30.0/24
107.8.109.110/24`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}