re = /((^|\.)((25[0-5])|(2[0-4]\d)|(1\d\d)|([1-9]?\d))){4}\/(?:\d|[12]\d|3[01])$/m
str = '10.120.15.30/28
172.181.30.0/24
107.8.109.110/24'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end