package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d\d/\w{3}/\d{4}:\d{2}:\d{2}:\d{2}))`)
var str = `in24.inetnebr.com - - [01/Aug/1995:00:00:01 -0400] "GET /shuttle/missions/sts-68/news/sts-68-mcc-05.txt HTTP/1.0" 200 1839`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}