package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d\d:\d\d\b`)
var str = `word word word (15:00 - - - 16:00 - - - 21:00)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}