package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<Name>meta content="(.*?)")`)
var str = `<meta content="Gizmo" property="og:title" />
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}