const regex = /(?<Name>meta content="(.*?)")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Name>meta content="(.*?)")', '')
const str = `<meta content="Gizmo" property="og:title" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}