#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<="Core #3 VID",)\n "SensorValue": "[0-9]+(\,[0-9]+)?"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Virtual Memory Commited"," & @CRLF & _
" "SensorValue": "31385"," & @CRLF & _
" "SensorUnit": "MB"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Virtual Memory Available"," & @CRLF & _
" "SensorValue": "5951"," & @CRLF & _
" "SensorUnit": "MB"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Virtual Memory Load"," & @CRLF & _
" "SensorValue": "84"," & @CRLF & _
" "SensorUnit": "%"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Physical Memory Used"," & @CRLF & _
" "SensorValue": "30134"," & @CRLF & _
" "SensorUnit": "MB"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Physical Memory Available"," & @CRLF & _
" "SensorValue": "2338"," & @CRLF & _
" "SensorUnit": "MB"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Physical Memory Load"," & @CRLF & _
" "SensorValue": "92,7"," & @CRLF & _
" "SensorUnit": "%"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "System"," & @CRLF & _
" "SensorName": "Page File Usage"," & @CRLF & _
" "SensorValue": "27,2209569027549"," & @CRLF & _
" "SensorUnit": "%"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #0 VID"," & @CRLF & _
" "SensorValue": "0,7376708984375"," & @CRLF & _
" "SensorUnit": "V"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #1 VID"," & @CRLF & _
" "SensorValue": "0,73828125"," & @CRLF & _
" "SensorUnit": "V"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #2 VID"," & @CRLF & _
" "SensorValue": "0,73828125"," & @CRLF & _
" "SensorUnit": "V"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #3 VID"," & @CRLF & _
" "SensorValue": "0,7449951171875"," & @CRLF & _
" "SensorUnit": "V"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #0 Clock"," & @CRLF & _
" "SensorValue": "983,934044334975"," & @CRLF & _
" "SensorUnit": "MHz"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #1 Clock"," & @CRLF & _
" "SensorValue": "983,934044334975"," & @CRLF & _
" "SensorUnit": "MHz"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "SensorApp": "HWiNFO"," & @CRLF & _
" "SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3"," & @CRLF & _
" "SensorName": "Core #2 Clock"," & @CRLF & _
" "SensorValue": "983,934044334975"," & @CRLF & _
" "SensorUnit": "MHz"," & @CRLF & _
" "SensorUpdateTime": 1558534280" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")