use strict;
my $str = '[
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Virtual Memory Commited",
"SensorValue": "31385",
"SensorUnit": "MB",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Virtual Memory Available",
"SensorValue": "5951",
"SensorUnit": "MB",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Virtual Memory Load",
"SensorValue": "84",
"SensorUnit": "%",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Physical Memory Used",
"SensorValue": "30134",
"SensorUnit": "MB",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Physical Memory Available",
"SensorValue": "2338",
"SensorUnit": "MB",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Physical Memory Load",
"SensorValue": "92,7",
"SensorUnit": "%",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "System",
"SensorName": "Page File Usage",
"SensorValue": "27,2209569027549",
"SensorUnit": "%",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #0 VID",
"SensorValue": "0,7376708984375",
"SensorUnit": "V",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #1 VID",
"SensorValue": "0,73828125",
"SensorUnit": "V",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #2 VID",
"SensorValue": "0,73828125",
"SensorUnit": "V",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #3 VID",
"SensorValue": "0,7449951171875",
"SensorUnit": "V",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #0 Clock",
"SensorValue": "983,934044334975",
"SensorUnit": "MHz",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #1 Clock",
"SensorValue": "983,934044334975",
"SensorUnit": "MHz",
"SensorUpdateTime": 1558534280
},
{
"SensorApp": "HWiNFO",
"SensorClass": "CPU [#0]: Intel Xeon E3-1225 v3",
"SensorName": "Core #2 Clock",
"SensorValue": "983,934044334975",
"SensorUnit": "MHz",
"SensorUpdateTime": 1558534280
},';
my $regex = qr/Core #3 VID"[^\:]+:\s\"(\d\,\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}