import re
regex = re.compile(r"Core #3 VID\"[^\:]+:\s\"(\d\,\d+)", flags=re.MULTILINE)
test_str = ("[\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Commited\",\n"
" \"SensorValue\": \"31385\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Available\",\n"
" \"SensorValue\": \"5951\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Load\",\n"
" \"SensorValue\": \"84\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Used\",\n"
" \"SensorValue\": \"30134\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Available\",\n"
" \"SensorValue\": \"2338\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Load\",\n"
" \"SensorValue\": \"92,7\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Page File Usage\",\n"
" \"SensorValue\": \"27,2209569027549\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #0 VID\",\n"
" \"SensorValue\": \"0,7376708984375\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #1 VID\",\n"
" \"SensorValue\": \"0,73828125\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #2 VID\",\n"
" \"SensorValue\": \"0,73828125\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #3 VID\",\n"
" \"SensorValue\": \"0,7449951171875\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #0 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #1 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #2 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")