using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Reg nr.*\r?\nInvoice(?: Nr\.)?\s*(?<arvenumber>(?<number>[^\W_]+)(?:_|\s+)[0-9]{1,2}\.[0-9]{1,2}\.[0-9]{4})\b";
string input = @"Reg nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714_01.05.2023
Kirjeldus
...
Sometimes it is terminated by newline
...
Reg nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714
01.05.2023
Kirjeldus
...
or by other white space delimiter and without Nr:
...
Reg nr_11687767_KMKR_EE101308591
Invoice M230714 01.05.2023
Kirjeldus
...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}