import Foundation
let pattern = #"^Reg nr.*\r?\nInvoice(?: Nr\.)?\s*(?<arvenumber>(?<number>[^\W_]+)(?:_|\s+)[0-9]{1,2}\.[0-9]{1,2}\.[0-9]{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Reg nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714_01.05.2023
Kirjeldus
...
Sometimes it is terminated by newline
...
Reg nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714
01.05.2023
Kirjeldus
...
or by other white space delimiter and without Nr:
...
Reg nr_11687767_KMKR_EE101308591
Invoice M230714 01.05.2023
Kirjeldus
...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)