package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Fa-f\d]{4}`)
var str = `8128
A0BC
T01B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}