$re = '/[A-Fa-f\d]{4}/';
$str = '8128
A0BC
T01B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);