$re = '/"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|[^,]+|(?<=^|,)(?=$|,)/';
$str = ', first,last,,44433"ll\\""34444,"k\\.",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);